Fixing Kenner Voice KITT

This forum contains discussions about all things Knight Rider.

Moderators: Matthew, neps, Michael Pajaro

Post Reply
KITTsMac
Stranger
Posts: 3
Joined: Wed Sep 25, 2002 1:01 am
What year did the original Knight Rider start: 0
Location: Washington
Contact:

Fixing Kenner Voice KITT

Post by KITTsMac » Fri Oct 18, 2013 4:08 pm

Hi,

I have a 1983 Kenner Voice KITT that I need assistance fixing. It was working just fine, but the plastic was not flush, so I took it apart to snap it back together correctly. However, the speed switch came loose. I couldn't get it to line up while putting the voicebox back in place, so in a brilliant move I opened up the voicebox to try and connect it from the other end. Up until this point, it still spoke. However, after opening the voicebox, now when I connect the battery the motor runs constantly and it doesn't play sound.

After Googling, I learned more about how it's supposed to work. From what I can tell, the rubber band is supposed to keep the motor from spinning. Mine is not broken, it's just wrapped around the record. I don't want to try anything else for fear of breaking it further.

Does anyone have instructions you could send me to help fix this? Pictures would be even better.

Thanks in advance!
Chris

KI2000PA
Volunteer
Posts: 11
Joined: Sun Mar 31, 2002 1:01 am
What year did the original Knight Rider start: 0
Location: Cumberland, Rhode Island
Contact:

Re: Fixing Kenner Voice KITT

Post by KI2000PA » Fri Nov 08, 2013 5:17 am

You are in luck sir for I can rebuild completely your entire Kenner KITT voice box and have it working like brand new, I have my original KITT voice car from the year of release and on occasion have had to change out the neoprene band a number of times all I used was a slightly smaller VCR neoprene band of the same type, so take heart I can help you

KITTsMac
Stranger
Posts: 3
Joined: Wed Sep 25, 2002 1:01 am
What year did the original Knight Rider start: 0
Location: Washington
Contact:

Re: Fixing Kenner Voice KITT

Post by KITTsMac » Fri Nov 08, 2013 11:23 am

Thanks for responding. The band on mine is not broken, so I think I can fix it myself. What would be great are instructions on how to properly reattach it, or better still a picture of how it's supposed to look.

Thank you so much for offering to help,
Chris

User avatar
superquad7
Volunteer
Posts: 5
Joined: Tue Mar 29, 2005 2:16 pm
What year did the original Knight Rider start: 0
Contact:

Re: Fixing Kenner Voice KITT

Post by superquad7 » Tue Dec 17, 2013 5:06 am

I'd be interested in reading more on this topic. Does anyone have any more information to share?

CB2001
FLAG Assistant
Posts: 567
Joined: Mon Jul 01, 2002 1:01 am
What year did the original Knight Rider start: 0
Location: Florida
Contact:

Re: Fixing Kenner Voice KITT

Post by CB2001 » Sat Feb 15, 2014 9:57 pm

The part that may not be working could be the electric motor on the inside of the voice box. When I got mine, it was the motor being locked up. All that was needed was a little oil to get it working and then reassemble the player. Basically, the voice box works like a record players, and inside is a disk similar to a record. But, there's a good chance you may end up needing to replace the motor entirely.

If it's not that, then you may also want to check the wires from the voice box to the battery compartment, as well as the battery compartment connections. If the compartment connections are corroded, then you may need to lean them or find some way to replace them.

Post Reply